Error encountered "mapping broken".

Discussion about the use of Simantics System Dynamics
Post Reply
nikbels
Posts: 4
Joined: April 7th, 2014, 11:58 am

Error encountered "mapping broken".

Post by nikbels » June 10th, 2014, 10:34 am

I have constructed a model and I am getting an error "mapping broken, please fix it".

But I don't have any other warnings like undeclared variable values- I have also connected the input and output variables accordingly.

What to do? I am attaching my file here for better clarification. Thanks in advance.
Attachments
Workforcemgmtsimplified.7z
(48.44 KiB) Downloaded 47 times
jkauttio
Site Admin
Posts: 5
Joined: February 13th, 2014, 1:41 pm

Re: Error encountered "mapping broken".

Post by jkauttio » June 10th, 2014, 2:04 pm

The actual problem seemed to be one erroneous predicate in the model which was probably created because of a bug in the tool, as it should be impossible to create otherwise. We are currently investigating the possible reasons for this but are fairly confident that this should not happen in the current development version of the tool.

If you happen to be still using the old version (1.7), we highly recommend you update to the most recent version (1.8) which was released recently.

The model also seemed to have few other non-related issues that prevented simulation:
  • The definition of Automation module is incomplete, so the model can not be simulated if it is in the diagram.
  • The Modelica syntax for if-then-else is slightly different from the one used in the model, but we do actually provide a similar shorthand for it which is IFTHENELSE().
  • Variable comparison inside if-then-else is done with two equals signs ("==") instead of one ("=").
A modified version of your model with all these issues fixed is available as an attachment. Thanks a lot for using Simantics System Dynamics!
Attachments
Workforcemgmtsimplified-fixed.zip
(82.08 KiB) Downloaded 49 times
Post Reply