Bug #7663

Regression in CompositeImage and diagram DnD monitors

Added by Tuukka Lehtonen 4 months ago. Updated 2 months ago.

Status:ClosedStart date:2017-11-07
Priority:4Due date:2017-11-20
Assignee:Tuukka Lehtonen% Done:


Category:-Spent time:-
Target version:2017-27
Release notes:
Tags: diagram, regression, dnd, monitor, 1.31.0
Story points-
Velocity based estimate-
ReleaseSimantics 1.31.0Release relationshipAuto


The method getOrCreateParentNode added to CompositeImage in #7523 and commit https://www.simantics.org/redmine/projects/simantics-platform/repository/platform-git/revisions/fb51fd7b6e8999e90c7769757ef4151c5f22243d breaks diagram DnD monitors because those are located in the scene graph directly under their parenting element's SingleElementNode (= element root node). The added code runs remove for all children of the parenting element and takes the DnD monitors with it to the grave.

I have no idea how to fix this regression without breaking what you originally set out to do with your change Antti.

7663-problem-visualization.png (355 KB) Tuukka Lehtonen, 2017-12-05 10:45 pm

Related issues

Related to Platform - Bug #7523: Update diagram element graphics when symbol graphics change Closed 2017-10-02 2017-10-02

Associated revisions

Revision 694cdd2b
Added by Tuukka Lehtonen 4 months ago

Potential fix for diagram scene graph screw-up regression

refs #7663

Change-Id: I092889d83fcfd653647e4de38984304461649b3f


#2 Updated by Tuukka Lehtonen 2 months ago

  • Due date set to 2017-11-20
  • Status changed from New to Closed
  • Target version set to 2017-27
  • Start date set to 2017-11-07
  • % Done changed from 0 to 100

#3 Updated by Tuukka Lehtonen 2 months ago

  • Assignee changed from Antti Villberg to Tuukka Lehtonen

Also available in: Atom PDF