Enhancement #6926

UpdateComponentUids shall create a map from old UIDs to new UIDs

Added by Tuukka Lehtonen about 1 year ago. Updated 11 months ago.

Status:ClosedStart date:2017-01-02
Priority:4Due date:2017-01-08
Assignee:Hannu Niemistö% Done:

100%

Category:-Spent time:-
Target version:2017-01
Release notes:Support migration of UIDs in synchronization structures when importing models
Tags: 1.22.3, 1.27.0, 1.22.2.1
Story points-
Velocity based estimate-
ReleaseSimantics 1.22.3Release relationshipAuto

Description

UpdateComponentUids creates a map from old uids to new uids. The map can be used to migrate also some other structures containing uids.

[PRIVATE-12930]

Change-Id: I9b621eb83a86dcf424b56010249e170cc4bc8741

Associated revisions

Revision 33424
Added by Tuukka Lehtonen about 1 year ago

UpdateComponentUids creates a map from old uids to new uids

The map can be used to migrate also some other structures containing
uids.

refs #6926
[PRIVATE-12930]

Change-Id: I9b621eb83a86dcf424b56010249e170cc4bc8741

Revision a7eaa6a7
Added by Tuukka Lehtonen about 1 year ago

Fixed NPE caused by previous change.

refs #6926

Change-Id: I43da3f39957c5832f1ebef32fa18f52adf8c1737

Revision 33425
Added by Tuukka Lehtonen about 1 year ago

Fixed NPE from previous commit r33424.

refs #6926
[PRIVATE-12930]

Change-Id: I43da3f39957c5832f1ebef32fa18f52adf8c1737

Revision 33448
Added by Tuukka Lehtonen 11 months ago

Merged /modeling/branches/simantics-1.22 r33424,r33425 to /modeling/branches/simantics-1.22.2.

For Simantics 1.22.2.1 service release.

refs #6926

History

#1 Updated by Tuukka Lehtonen about 1 year ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 100

#3 Updated by Tuukka Lehtonen about 1 year ago

  • Description updated (diff)

#5 Updated by Tuukka Lehtonen about 1 year ago

  • Status changed from Resolved to Closed

#6 Updated by Tuukka Lehtonen about 1 year ago

  • Tags changed from 1.22.3, 1.26.0 to 1.22.3, 1.27.0

#7 Updated by Hannu Niemistö 11 months ago

  • Release notes set to Migrate unique ids in synchronization structures when importing models

#8 Updated by Hannu Niemistö 11 months ago

  • Release notes changed from Migrate unique ids in synchronization structures when importing models to Support migration of UIDs in synchronization structures when importing models

#9 Updated by Tuukka Lehtonen 11 months ago

  • Tags changed from 1.22.3, 1.27.0 to 1.22.3, 1.27.0, 1.22.2.1

Also available in: Atom PDF