Bug #5763

StandardGraphPropertyVariable no longer returns child index variables for array property variables

Added by Tuukka Lehtonen about 2 years ago. Updated almost 2 years ago.

Status:ClosedStart date:2014-11-10
Priority:4Due date:2014-11-10
Assignee:Tuukka Lehtonen% Done:

100%

Category:VariableSpent time:1.00 hour
Target version:1.18.1
Release notes:Fixed StandardGraphPropertyVariable regression caused by r30486 in Simantics 1.17.1.
Tags: regression
Story points-
Velocity based estimate-
ReleaseSimantics 1.18.1Release relationshipAuto

Description

This code:

        final Variable indexVariable = editedVariable.getPossibleChild(graph, range.toChildReferenceString());
        if (indexVariable == null)
            throw new UnsupportedOperationException("index variables not supported " + editedVariable.getURI(graph));

now fails but was working in versions prior to 1.17.1.

The regression was caused by r30486 which changed StandardGraphPropertyVariable.getPossibleChildVariableMap to return null if there is no Resource representation for the variable which it didn't previously do.


Related issues

Follows Platform - Enhancement #5419: Performance enhancements for DB client Closed 2014-10-18 2014-11-07

Associated revisions

Revision 31166
Added by Tuukka Lehtonen about 2 years ago

Fixed StandardGraphPropertyVariable.getPossibleChildVariableMap to return All.standardPropertyDomainChildren instead of null if there property variable has no resource representation.

This fixes behaviour committed in r30486 that broke previous use cases where indexing of an array property variable was attempted using getPossibleChild or similar methods.

refs #5763

Revision 31168
Added by Tuukka Lehtonen about 2 years ago

Merged trunk@31166 to branches/simantics-1.18 on 2015-04-13 for 1.18.1 release.

refs #5763

History

#1 Updated by Tuukka Lehtonen about 2 years ago

  • Status changed from New to Closed
  • % Done changed from 0 to 100

#2 Updated by Tuukka Lehtonen almost 2 years ago

  • Release notes set to Fixed StandardGraphPropertyVariable regression caused by r30486 in Simantics 1.17.1.

Also available in: Atom PDF