Feature #5670

Trash bin for deleted resources

Added by Antti Villberg over 2 years ago. Updated over 2 years ago.

Status:ClosedStart date:2015-02-16
Priority:4Due date:2015-03-02
Assignee:Antti Villberg% Done:

100%

Category:-Spent time:-
Target version:1.18.1
Release notes:Added http://Projects/TrashBin folder for storing deleted models until they are eventually garbage collected, i.e. deleted from there using optimized code. See *Simantics/DBSupport* SCL module for the related SCL function *emptyTrashBin*.
Tags: scl, db, trashbin
Story points-
Velocity based estimate-
ReleaseSimantics 1.18.1Release relationshipAuto

Related issues

Related to Platform - Bug #5744: Search service does not ensure well enough the search tem... Closed 2015-03-24 2015-03-24
Related to Platform - Bug #5745: MigrationUtils.importMigratedMany does unnecessary work m... Closed 2015-03-24 2015-03-24
Related to Platform - Bug #5824: Empty Database Trash Bin can cause database undo to fail Closed 2015-05-04 2015-05-04

Associated revisions

Revision 30931
Added by Antti Villberg over 2 years ago

(refs #5670) Trash bin for deleted resources.
Initial support for trash bin - based removers. Cleanup operation available in SCL console.

Revision 30944
Added by Tuukka Lehtonen over 2 years ago

Merged trunk@30931 to branches/simantics-1.18 on 2015-02-19 for 1.18.1 release.

refs #5670

Revision 30948
Added by Tuukka Lehtonen over 2 years ago

Added IProgressMonitor.isCanceled handling into MigrationUtils.importMigratedMany and MigrationSequence.

The code uses TrashBinRemover to throw away the material that may have been imported into the temporary index root used by the import procedure.

refs #5670

Revision 30949
Added by Tuukka Lehtonen over 2 years ago

Merged trunk@30948 to branches/simantics-1.18 on 2015-02-19 for 1.18.1 release.

refs #5670

Revision 31063
Added by Tuukka Lehtonen over 2 years ago

Added progress monitor support to Layer0Utils.emptyTrashBin and moved emptyTrashBin function to Simantics/DBSupport SCL module.

refs #5670

Revision 31065
Added by Tuukka Lehtonen over 2 years ago

Merged trunk@31063 to branches/simantics-1.18 on 2015-03-11 for 1.18.1 release.

refs #5670

Revision 31114
Added by Antti Villberg over 2 years ago

refs #5670
Move more stuff into tempFiles and try to clean up indices for deleted index roots. Clean tempFiles also after purge.

Revision 31115
Added by Antti Villberg over 2 years ago

Merged revision(s) 31114 from db/trunk/org.simantics.db.layer0:
refs #5670
Move more stuff into tempFiles and try to clean up indices for deleted index roots. Clean tempFiles also after purge.
........

History

#1 Updated by Tuukka Lehtonen over 2 years ago

  • Status changed from New to In Progress

#2 Updated by Tuukka Lehtonen over 2 years ago

  • Assignee set to Antti Villberg

#3 Updated by Tuukka Lehtonen over 2 years ago

  • % Done changed from 0 to 50
  • Release set to 17

#4 Updated by Tuukka Lehtonen over 2 years ago

  • Tags set to db, trashbin

#5 Updated by Tuukka Lehtonen over 2 years ago

The change to SWTWikiBrowser made in r30948 was because I ran into this:

Caused by: java.lang.NullPointerException
    at org.simantics.views.swt.client.impl.SWTWikiBrowser.createControls(SWTWikiBrowser.java:84)
    at org.simantics.views.swt.client.base.SWTParentNode.createChildComposites(SWTParentNode.java:118)
    at org.simantics.views.swt.client.impl.SWTScrolledComposite.createControls(SWTScrolledComposite.java:115)
    at org.simantics.views.swt.client.base.SWTParentNode.createChildComposites(SWTParentNode.java:118)
    at org.simantics.views.swt.client.base.SWTParentNode.createChildComposites(SWTParentNode.java:114)
    at org.simantics.views.swt.client.impl.SWTSashForm.createControls(SWTSashForm.java:23)
    at org.simantics.views.swt.client.impl.SWTAlternative.createControls(SWTAlternative.java:40)
    at org.simantics.views.swt.client.impl.SWTAlternative.synchronizeCondition(SWTAlternative.java:72)
    ... 31 more

when destroying a model right after selecting it from the model browser. SWTAWTComposite.syncPopulate can return without ever finishing the actual control creation if the UI was disposed before the AWT-thread contstruction began.

#6 Updated by Tuukka Lehtonen over 2 years ago

  • Status changed from In Progress to Closed

#7 Updated by Tuukka Lehtonen over 2 years ago

  • Release notes set to Added http://Projects/TrashBin folder for storing deleted models until they are eventually garbage collected, i.e. deleted from there using optimized code. See *Simantics/DBSupport* SCL module for the related SCL function *emptyTrashBin*.

#8 Updated by Tuukka Lehtonen over 2 years ago

  • % Done changed from 50 to 100

#9 Updated by Tuukka Lehtonen over 2 years ago

  • Tags changed from db, trashbin to db, trashbin, scl

Also available in: Atom PDF