Bug #5655

TerminalInformer leaves disposed SWT images in use in the status bar - breaks the workbench UI

Added by Tuukka Lehtonen about 2 years ago. Updated about 2 years ago.

Status:ClosedStart date:2015-02-06
Priority:4Due date:2015-02-06
Assignee:Tuukka Lehtonen% Done:

100%

Category:DiagramSpent time:0.25 hour
Target version:1.18.1
Release notes:Removed green bullet image from the terminal info shown in the status line when the control key is pressed and hovering on top of an element terminal.
Tags: diagram, terminal
Story points-
Velocity based estimate-
ReleaseSimantics 1.18.1Release relationshipAuto

Description

For some (for now) unknown reason, TerminalInformer in its current state tends to leave an SWT Image set in the status line's message, which will get disposed later on but never actually removed from the status line message.

This causes unexpected exceptions to occur inside Eclipse code which wreaks havoc to the general workbench UI functionality.

The best solution at this point is to remove the image use from TerminalInformer to get rid of the nasty side effects easily.

Associated revisions

Revision 30885
Added by Tuukka Lehtonen about 2 years ago

Removed SWT Image use from TermiinalInformer when setting the status line message to avoid UI breakage caused by the status line containing a message with a disposed image.

refs #5655

History

#1 Updated by Tuukka Lehtonen about 2 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 0 to 100

#2 Updated by Tuukka Lehtonen about 2 years ago

  • Status changed from Resolved to Closed

Merged to simantics-1.18 branch in r30886.

Also available in: Atom PDF