Bug #5532

Unwanted exception thrown from RuntimeVariable.perform when a model is removed with diagrams open from it

Added by Tuukka Lehtonen about 3 years ago. Updated about 3 years ago.

Status:ClosedStart date:2014-10-16
Priority:4Due date:2014-10-17
Assignee:Tuukka Lehtonen% Done:

100%

Category:DiagramSpent time:-
Target version:1.13.5
Release notes:
Tags: diagram
Story points1.0
Velocity based estimate-
ReleaseSimantics 1.13.5Release relationshipAuto

Description

!ENTRY org.simantics.utils.ui 4 0 2014-12-05 10:29:17.576
!MESSAGE org.simantics.db.exception.AssumptionException: resource [id=$438277] does not have a parent
resource [id=$438277] does not have a parent

!STACK 0
org.simantics.db.exception.AssumptionException: org.simantics.db.exception.AssumptionException: resource [id=$438277] does not have a parent
    at org.simantics.db.impl.graph.ReadGraphImpl.getURI(ReadGraphImpl.java:227)
    at org.simantics.diagram.runtime.RuntimeVariable.perform(RuntimeVariable.java:75)
    at org.simantics.diagram.runtime.RuntimeVariable.perform(RuntimeVariable.java:1)
    at org.simantics.db.impl.query.QueryProcessor.performForEach(QueryProcessor.java:1051)
    at org.simantics.db.impl.query.QueryProcessor.queryRead(QueryProcessor.java:854)
    at org.simantics.db.impl.graph.ReadGraphImpl.syncRequest(ReadGraphImpl.java:1887)
    at org.simantics.diagram.runtime.RuntimeVariableForInput.perform(RuntimeVariableForInput.java:46)
    at org.simantics.diagram.runtime.RuntimeVariableForInput.perform(RuntimeVariableForInput.java:1)
    at org.simantics.db.impl.query.ReadEntry$1.recompute(ReadEntry.java:87)
    at org.simantics.db.impl.query.QueryProcessor.compareTo(QueryProcessor.java:2385)
    at org.simantics.db.impl.query.QueryProcessor.performScheduledUpdates(QueryProcessor.java:2466)
    at fi.vtt.simantics.procore.internal.State.commitWriteTransaction(State.java:352)
    at fi.vtt.simantics.procore.internal.SessionRequestManager$4.run(SessionRequestManager.java:240)
    at org.simantics.db.impl.query.QueryThread.run(QueryThread.java:251)
Caused by: org.simantics.db.exception.AssumptionException: resource [id=$438277] does not have a parent
    at org.simantics.db.common.uri.ResourceToURI.perform(ResourceToURI.java:48)
    at org.simantics.db.common.uri.ResourceToURI.perform(ResourceToURI.java:1)
    at org.simantics.db.impl.query.QueryProcessor.performForEach(QueryProcessor.java:1051)
    at org.simantics.db.impl.query.QueryProcessor.queryRead(QueryProcessor.java:854)
    at org.simantics.db.impl.graph.ReadGraphImpl.syncRequest(ReadGraphImpl.java:1887)
    at org.simantics.db.common.uri.ResourceToURI.perform(ResourceToURI.java:50)
    at org.simantics.db.common.uri.ResourceToURI.perform(ResourceToURI.java:1)
    at org.simantics.db.impl.query.QueryProcessor.performForEach(QueryProcessor.java:1051)
    at org.simantics.db.impl.query.QueryProcessor.queryRead(QueryProcessor.java:854)
    at org.simantics.db.impl.graph.ReadGraphImpl.syncRequest(ReadGraphImpl.java:1887)
    at org.simantics.db.common.uri.ResourceToURI.perform(ResourceToURI.java:50)
    at org.simantics.db.common.uri.ResourceToURI.perform(ResourceToURI.java:1)
    at org.simantics.db.impl.query.QueryProcessor.performForEach(QueryProcessor.java:1051)
    at org.simantics.db.impl.query.QueryProcessor.queryRead(QueryProcessor.java:854)
    at org.simantics.db.impl.graph.ReadGraphImpl.syncRequest(ReadGraphImpl.java:1887)
    at org.simantics.db.impl.graph.ReadGraphImpl.getURI(ReadGraphImpl.java:223)
    at org.simantics.db.layer0.variable.Variables.getVariable(Variables.java:168)
    at fi.vtt.apros.ui.function.Func.diagramTransformation(Func.java:1763)
    at sun.reflect.GeneratedMethodAccessor37.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:483)
    at org.simantics.scl.reflection.functions.ClassMethodFunction.doApply(ClassMethodFunction.java:23)
    at org.simantics.scl.runtime.function.FunctionImplN.applyArray(FunctionImplN.java:144)
    at org.simantics.db.common.utils.Functions.exec(Functions.java:25)
    at org.simantics.selectionview.StandardSelectionProcessor.processStatic(StandardSelectionProcessor.java:88)
    at org.simantics.selectionview.StandardSelectionProcessor.process(StandardSelectionProcessor.java:51)
    at org.simantics.selectionview.StandardSelectionProcessor.process(StandardSelectionProcessor.java:1)
    at org.simantics.selectionview.StandardProperties$1.process(StandardProperties.java:65)
    at org.simantics.selectionview.StandardProperties$1.process(StandardProperties.java:1)
    at org.simantics.selectionview.TabbedPropertyTable$5$1.perform(TabbedPropertyTable.java:267)
    at org.simantics.selectionview.TabbedPropertyTable$5$1.perform(TabbedPropertyTable.java:1)
    ... 6 more

Related issues

Copied from Platform - Feature #5408: Active diagram profile selection should be model specific Closed 2014-10-16 2014-10-17

Associated revisions

Revision 30649
Added by Tuukka Lehtonen about 3 years ago

getURI => getPossibleURI to prevent unwanted exceptions.

refs #5532

Revision 30650
Added by Tuukka Lehtonen about 3 years ago

getURI => getPossibleURI to prevent unwanted exceptions.

refs #5532

History

#1 Updated by Tuukka Lehtonen about 3 years ago

  • Description updated (diff)

#2 Updated by Tuukka Lehtonen about 3 years ago

  • Status changed from New to Closed

Also available in: Atom PDF