Enhancement #5472

SCL compiler API refactoring

Added by Hannu Niemistö over 2 years ago. Updated almost 2 years ago.

Status:ClosedStart date:2014-11-12
Priority:4Due date:2015-01-16
Assignee:Hannu Niemistö% Done:

100%

Category:-Spent time:-
Target version:1.18.1
Release notes:* Improved API to SCL module and expression compiler including classes representing compilation environments
* Expression compilation speed improvements: some expressions are compiled even 10 times faster
Tags: scl
Story points-
Velocity based estimate-
ReleaseSimantics 1.18.1Release relationshipAuto

Description

In this ticket SCL compiler API for getting modules and compiling expressions is completely rewritten. This should provide
  • Recompiling modules whose source code has been changed and their dependencies
  • Speed inprovements in expression compilation
  • Easier way to provide context specific variables to expressions
  • Concept of environment that can also be used to compile for example type expressions

Associated revisions

Revision 30549
Added by Hannu Niemistö over 2 years ago

(refs #5472) Integrated new SCL compiler interface to Simantics codebase

Revision 30550
Added by Hannu Niemistö over 2 years ago

(refs #5472) Integrated new SCL compiler interface to Simantics codebase, removals

Revision 30551
Added by Hannu Niemistö over 2 years ago

(refs #5472) Integrated new SCL compiler interface to Simantics codebase

Revision 30552
Added by Hannu Niemistö over 2 years ago

(refs #5472) Integrated new SCL compiler interface to Simantics codebase, removals

Revision 30553
Added by Hannu Niemistö over 2 years ago

(refs #5472) Fixed ServerSCLValueRequest

Revision 30554
Added by Tuukka Lehtonen over 2 years ago

Fixing fallout from Hannu's SCL megamix:
  • re-export org.simantics.scl.compiler from org.simantics.scl.osgi
  • remove org.simantics.scl.prelude dependencies from everywhere since it has been totally deprecated for a while now
  • Fixed ScriptTestBase to use CommandSession

refs #5472

Revision 30557
Added by Tuukka Lehtonen over 2 years ago

org.simantics.scl.prelude is deprecated and should no longer be included in the org.simantics.scl feature.

refs #5472

Revision 30558
Added by Hannu Niemistö over 2 years ago

(refs #5472) Integrated new SCL compiler interface to Simantics codebase, removals

Revision 30559
Added by Hannu Niemistö over 2 years ago

(refs #5472) Integrated new SCL compiler interface to Simantics codebase, removals

Revision 30560
Added by Tuukka Lehtonen over 2 years ago

Reverted invalid SCLCommandSession -> CommandSession renaming in ModelingResources.

refs #5472

Revision 30561
Added by Hannu Niemistö over 2 years ago

(refs #5472) fixed build.properties of org.simantics.scl.db

Revision 30562
Added by Hannu Niemistö over 2 years ago

(refs #5472) bugfixes after SCL compiler integration

Revision 30563
Added by Hannu Niemistö over 2 years ago

(refs #5472) class loading bugfixes after SCL compiler integration

Revision 30564
Added by Hannu Niemistö over 2 years ago

(refs #5472) escaping unicode characters in java source

Revision 30565
Added by Tuukka Lehtonen over 2 years ago

Reverted invalid SCLCommandSession -> CommandSession renaming in ModelingResources.

refs #5472

Revision 30566
Added by Hannu Niemistö over 2 years ago

(refs #5472) priority mechanism for module sources

Revision 30567
Added by Antti Villberg over 2 years ago

(refs #5472) ExternalRead procedure needs to be called once even when disposed

Revision 30568
Added by Hannu Niemistö over 2 years ago

(refs #5472) bugfix in ServiceBasedModuleSourceRepository, error annotations in editor

Revision 30569
Added by Hannu Niemistö over 2 years ago

(refs #5472) updating graph modules

Revision 30570
Added by Hannu Niemistö over 2 years ago

(refs #5472) fixed reflection code in the compilation path of the ExpressionEvaluator

Revision 30571
Added by Hannu Niemistö over 2 years ago

(refs #5472) always fills errors array in SCLExpressionCompilationException

Revision 30572
Added by Hannu Niemistö over 2 years ago

(refs #5472) parent class loader to ExpressionClassLoader

Revision 30573
Added by Hannu Niemistö over 2 years ago

(refs #5472) changed escaping char from @ to \u00a5

Revision 30574
Added by Hannu Niemistö over 2 years ago

(refs #5472) changed escaping char from . to \u00a3

Revision 30575
Added by Hannu Niemistö over 2 years ago

(refs #5472) better class loader for GraphModuleLoader

Revision 30576
Added by Hannu Niemistö over 2 years ago

(refs #5472) try to load non-scl classes from all parent module class loaders

Revision 30577
Added by Hannu Niemistö over 2 years ago

(refs #5472) give graph to compiler when firing update

Revision 30578
Added by Hannu Niemistö over 2 years ago

(refs #5472) remove unnecessary synchronization

Revision 30580
Added by Hannu Niemistö over 2 years ago

(refs #5472) added back printingToFile, enabled interpretation of expressions, some new debuging flags

Revision 30581
Added by Hannu Niemistö over 2 years ago

(refs #5472) fromDynamic, automatic conversion of values from getPropertyValue

Revision 30582
Added by Hannu Niemistö over 2 years ago

(refs #5472) include compiler to the class loading of prelude

Revision 30583
Added by Hannu Niemistö over 2 years ago

(refs #5472) replace "://" by a special character in class names

Revision 30584
Added by Hannu Niemistö over 2 years ago

(refs #5472) yet another fix to class name escaping

Revision 30585
Added by Hannu Niemistö over 2 years ago

(refs #5472) conversion of scl value from getProperty

Revision 30586
Added by Hannu Niemistö over 2 years ago

(refs #5472) use Environments.getType for type conversion when reading component type properties

Revision 30588
Added by Hannu Niemistö over 2 years ago

(refs #5472) fixed runFromFile and reset

Revision 30589
Added by Hannu Niemistö over 2 years ago

(refs #5472) removed debug prints

Revision 30590
Added by Hannu Niemistö over 2 years ago

(refs #5472) removed debug prints

Revision 30592
Added by Antti Villberg over 2 years ago

(refs #5472) Fixes after API changes in Simupedia applications

Revision 30596
Added by Antti Villberg over 2 years ago

(refs #5472) Fixes after API changes in Simupedia applications

Revision 30599
Added by Antti Villberg over 2 years ago

(refs #5472) Fixes after API changes in Simupedia applications

Revision 30608
Added by Antti Villberg over 2 years ago

(refs #5472) SCL compiler API refactoring
Possible fix for module compilation updates

Revision 30617
Added by Antti Villberg over 2 years ago

(refs #5472) SCL compiler API refactoring
Added sone SCLMains to ontologies to handle missing dependencies in ontology-defined SCL values

Revision 30627
Added by Antti Villberg over 2 years ago

(refs #5472) Refreshing of editors and expressions after module changes

Revision 30631
Added by Hannu Niemistö over 2 years ago

(refs #5472) fixed resolving of names like MOD.SCLQuery.text

Revision 30657
Added by Antti Villberg over 2 years ago

(refs #5472) Allow evaluation of expressions even when structural context is not available

Revision 30660
Added by Tuukka Lehtonen over 2 years ago

Fixed regression caused by SCL compiler update in modelled MOD.sclActions.
Now sclTest and sclAction should work again.

refs #5472

Revision 30678
Added by tuorjr over 2 years ago

(refs #5472) Added an escape character for the percent sign.

Revision 30680
Added by Hannu Niemistö over 2 years ago

(refs #5472) Improved SCL module escaping

Revision 30681
Added by tuorjr over 2 years ago

(refs #5472) Fixed escaping of double slashes.

Revision 30687
Added by Hannu Niemistö over 2 years ago

(refs #5472) Added stop button

Revision 30693
Added by Hannu Niemistö over 2 years ago

(refs #5472) Replaced Printer-interface with CommandResponseHandler interface

Revision 30702
Added by Hannu Niemistö over 2 years ago

(refs #5472) merged changes from git repo

Revision 30703
Added by Hannu Niemistö over 2 years ago

(refs #5472) merged changes from git repo

Revision 30704
Added by Hannu Niemistö over 2 years ago

(refs #5472) merged changes from git repo

Revision 30749
Added by Hannu Niemistö over 2 years ago

(refs #5472) Added back support for importing modules from file system

Revision 30757
Added by Hannu Niemistö over 2 years ago

(refs #5472) Added back content assist for local names, interpret _ as lowercase letter in patterns

History

#1 Updated by Hannu Niemistö over 2 years ago

  • Tags set to scl

#2 Updated by Hannu Niemistö over 2 years ago

  • Status changed from In Progress to Resolved

#3 Updated by Hannu Niemistö over 2 years ago

  • Release notes set to * Improved API to SCL module and expression compiler including classes representing compilation environments * Expression compilation speed improvements: some expressions are compiled even 10 times faster

#4 Updated by Tuukka Lehtonen over 2 years ago

  • Release set to 17

#5 Updated by Tuukka Lehtonen over 2 years ago

  • Status changed from Resolved to Closed

#6 Updated by Tuukka Lehtonen almost 2 years ago

  • % Done changed from 0 to 100

Also available in: Atom PDF