Bug #4689

AssumptionException while trying to browse GraphDebugger to http://www.simantics.org/Breakdown-1.0

Added by Jani Simomaa about 4 years ago. Updated about 4 years ago.

Status:ClosedStart date:
Priority:4Due date:
Assignee:Antti Villberg% Done:

100%

Category:-Spent time:-
Target version:1.13.1
Release notes:
Story pointsS
Velocity based estimate-
ReleaseSimantics 1.13.2Release relationshipAuto

Description

AssumptionException while trying to browse GraphDebugger to http://www.simantics.org/Breakdown-1.0

org.simantics.db.exception.AssumptionException: org.simantics.db.exception.AssumptionException: resource [id=$16419] does not have a name
    at org.simantics.db.impl.graph.ReadGraphImpl.getURI(ReadGraphImpl.java:219)
    at org.simantics.debug.ui.GraphDebugger.updateContent(GraphDebugger.java:1169)
    at org.simantics.debug.ui.GraphDebugger$7.run(GraphDebugger.java:662)
    at org.simantics.db.common.request.ReadRequest.perform(ReadRequest.java:21)
    at fi.vtt.simantics.procore.internal.SessionImplSocket$6.run(SessionImplSocket.java:1517)
    at fi.vtt.simantics.procore.internal.SessionRequestManager$1.run(SessionRequestManager.java:123)
    at org.simantics.db.impl.query.QueryThread.run(QueryThread.java:239)
Caused by: org.simantics.db.exception.AssumptionException: resource [id=$16419] does not have a name
    at org.simantics.db.common.uri.ResourceToURI.perform(ResourceToURI.java:43)
    at org.simantics.db.common.uri.ResourceToURI.perform(ResourceToURI.java:1)
    at org.simantics.db.impl.query.QueryProcessor.tryQuery(QueryProcessor.java:4874)
    at org.simantics.db.impl.graph.ReadGraphImpl.syncRequest(ReadGraphImpl.java:1628)
    at org.simantics.db.impl.graph.ReadGraphImpl.getURI(ReadGraphImpl.java:215)
    ... 6 more

History

#1 Updated by Jani Simomaa about 4 years ago

  • Description updated (diff)

#2 Updated by Tuukka Lehtonen about 4 years ago

  • Status changed from New to Feedback
  • Assignee set to Antti Villberg
  • Target version set to 1.13.1
  • % Done changed from 0 to 100

I believe this was fixed by r28754?

#3 Updated by Tuukka Lehtonen about 4 years ago

  • Status changed from Feedback to Resolved

#4 Updated by Tuukka Lehtonen about 4 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF