Bug #4687

NPE in Subscription CSV export

Added by Tuukka Lehtonen about 4 years ago. Updated about 4 years ago.

Status:ClosedStart date:
Priority:4Due date:
Assignee:Tuukka Lehtonen% Done:

100%

Category:ChartSpent time:-
Target version:1.13.1
Release notes:
Story pointsS
Velocity based estimate-
ReleaseSimantics 1.13.2Release relationshipAuto

Description

2014-01-31 08:26:47,709 3620402 [   ModalContext] ERROR ics.db.common.utils.LogManager - Unexpected exception
org.eclipse.core.commands.ExecutionException: Unexpected exception
    at org.simantics.charts.ui.CSVExporter.doExport(CSVExporter.java:180)
    at org.simantics.charts.ui.CSVExporter.exportModel(CSVExporter.java:88)
    at org.simantics.charts.ui.CSVExporter.run(CSVExporter.java:73)
    at org.eclipse.jface.operation.ModalContext$ModalContextThread.run(ModalContext.java:121)
Caused by: org.simantics.db.exception.DatabaseException: Unexpected exception
    at fi.vtt.simantics.procore.internal.SessionImplSocket.syncRequest(SessionImplSocket.java:1797)
    at fi.vtt.simantics.procore.internal.SessionImplSocket.syncRequest(SessionImplSocket.java:2877)
    at org.simantics.db.common.request.UniqueRead.request(UniqueRead.java:60)
    at fi.vtt.simantics.procore.internal.SessionImplSocket.sync(SessionImplSocket.java:2184)
    at org.simantics.charts.ui.CSVExporter.doExport(CSVExporter.java:177)
    ... 3 more
Caused by: java.lang.NullPointerException
    at org.simantics.modeling.subscription.SubscriptionItemLabel.removeVariablePrefixPath(SubscriptionItemLabel.java:109)
    at org.simantics.charts.ui.CSVParamsQuery.run(CSVParamsQuery.java:72)
    at org.simantics.db.common.request.ReadRequest.perform(ReadRequest.java:21)
    at fi.vtt.simantics.procore.internal.SessionImplSocket$6.run(SessionImplSocket.java:1517)
    at fi.vtt.simantics.procore.internal.SessionRequestManager$1.run(SessionRequestManager.java:123)
    at org.simantics.db.impl.query.QueryThread.run(QueryThread.java:239)

Caused by CSVParamsQuery being out of date compared to ChartItemLabelRule.

Associated revisions

Revision 28738
Added by Tuukka Lehtonen about 4 years ago

Subscription item labeling logic from ChartItemLabelRule added to CSVParamsQuery.

fixes #4687

History

#1 Updated by Tuukka Lehtonen about 4 years ago

  • Description updated (diff)
  • Category set to Chart
  • Status changed from New to In Progress
  • Assignee set to Tuukka Lehtonen

#2 Updated by Tuukka Lehtonen about 4 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 0 to 100

Applied in changeset r28738.

#3 Updated by Tuukka Lehtonen about 4 years ago

Applied in changeset r28738.

#4 Updated by Tuukka Lehtonen about 4 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF