Bug #4581

Creating a Typical Diagram under shared library fails

Added by Jani Simomaa about 4 years ago. Updated almost 4 years ago.

Status:ClosedStart date:
Priority:4Due date:
Assignee:Tuukka Lehtonen% Done:

100%

Category:TypicalsSpent time:-
Target version:1.13.1
Release notes:
Story pointsS
Velocity based estimate-
ReleaseSimantics 1.13.2Release relationshipAuto

Description

Trying to create Typical Diagram under a shared library fails with exception:

!ENTRY org.eclipse.ui 4 0 2013-12-05 08:42:50.793
!MESSAGE Unhandled event loop exception
!STACK 0
org.eclipse.swt.SWTException: Failed to execute runnable (java.lang.NullPointerException: null input)
    at org.eclipse.swt.SWT.error(SWT.java:4282)
    at org.eclipse.swt.SWT.error(SWT.java:4197)
    at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:138)
    at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:4140)
    at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3757)
    at org.eclipse.jface.window.Window.runEventLoop(Window.java:825)
    at org.eclipse.jface.window.Window.open(Window.java:801)
    at org.eclipse.jface.dialogs.MessageDialog.open(MessageDialog.java:334)
    at org.eclipse.jface.dialogs.MessageDialog.open(MessageDialog.java:364)
    at org.eclipse.jface.dialogs.MessageDialog.openInformation(MessageDialog.java:446)
    at org.simantics.utils.ui.dialogs.ShowMessage.run(ShowMessage.java:91)
    at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:35)
    at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:135)
    at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:4140)
    at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3757)
    at org.eclipse.jface.operation.ModalContext$ModalContextThread.block(ModalContext.java:173)
    at org.eclipse.jface.operation.ModalContext.run(ModalContext.java:388)
    at org.eclipse.jface.dialogs.ProgressMonitorDialog.run(ProgressMonitorDialog.java:507)
    at org.eclipse.ui.internal.progress.ProgressMonitorJobsDialog.run(ProgressMonitorJobsDialog.java:275)
    at org.eclipse.ui.internal.progress.ProgressManager$5.run(ProgressManager.java:960)
    at org.eclipse.swt.custom.BusyIndicator.showWhile(BusyIndicator.java:70)
    at org.eclipse.ui.internal.progress.ProgressManager.busyCursorWhile(ProgressManager.java:995)
    at org.eclipse.ui.internal.progress.ProgressManager.busyCursorWhile(ProgressManager.java:970)
    at org.simantics.modeling.ui.typicals.NewMasterTypicalDiagram$1.run(NewMasterTypicalDiagram.java:61)
    at org.simantics.browsing.ui.model.actions.ActionContribution$1.run(ActionContribution.java:87)
    at org.eclipse.jface.action.Action.runWithEvent(Action.java:498)
    at org.eclipse.jface.action.ActionContributionItem.handleWidgetSelection(ActionContributionItem.java:584)
    at org.eclipse.jface.action.ActionContributionItem.access$2(ActionContributionItem.java:501)
    at org.eclipse.jface.action.ActionContributionItem$5.handleEvent(ActionContributionItem.java:411)
    at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
    at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1053)
    at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:4165)
    at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3754)
    at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:2696)
    at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2660)
    at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:2494)
    at org.eclipse.ui.internal.Workbench$7.run(Workbench.java:674)
    at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
    at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:667)
    at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:149)
    at org.simantics.workbench.internal.SimanticsWorkbenchApplication.start(SimanticsWorkbenchApplication.java:138)
    at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:344)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:606)
    at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:622)
    at org.eclipse.equinox.launcher.Main.basicRun(Main.java:577)
    at org.eclipse.equinox.launcher.Main.run(Main.java:1410)
    at org.eclipse.equinox.launcher.Main.main(Main.java:1386)
Caused by: java.lang.NullPointerException: null input
    at org.simantics.ui.workbench.action.ChooseActionRequest.<init>(ChooseActionRequest.java:106)
    at org.simantics.modeling.ui.typicals.NewMasterTypicalDiagram$2.run(NewMasterTypicalDiagram.java:91)
    at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:35)
    at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:135)
    ... 51 more

Also following error dialog is shown for the user

error.PNG (20.6 KB) Jani Simomaa, 2013-12-05 08:49 am

Associated revisions

Revision 28653
Added by Tuukka Lehtonen about 4 years ago

Prevent AssignDiagramTemplate action from being shown for typicals in shared libraries.

refs #4581

Revision 28654
Added by Tuukka Lehtonen about 4 years ago

Make it possible to create typical masters in shared libraries.
refs #4581

Revision 28655
Added by Tuukka Lehtonen about 4 years ago

Organized imports / icPage -> migratePage.
refs #4581

Revision 28716
Added by Tuukka Lehtonen about 4 years ago

Renamed ontology property from namingFunction to typicalNamingFunction to prevent property name clashes.

refs #4581

Revision 28721
Added by Tuukka Lehtonen about 4 years ago

Fixed NavigateToTarget to not crash if user has managed to create a connected flag somewhere outside of a model's configuration, such as a typical master diagram and the user tries to navigate through it to the other diagram.

Now the code will show an error message in the workbench status bar: Navigating via flags only possible under model configuration if the user tries to do this instead of crashing with an unexpected exception.

refs #4581

Revision 28944
Added by Tuukka Lehtonen almost 4 years ago

Platform support for defining (asserting) diagram element type specific typical diagram element synchronization rules.

refs #4581

History

#1 Updated by Jani Simomaa about 4 years ago

#2 Updated by Tuukka Lehtonen about 4 years ago

  • Target version set to 1.13.1

#3 Updated by Tuukka Lehtonen about 4 years ago

  • Status changed from New to Feedback
  • Assignee set to Tuukka Lehtonen
  • % Done changed from 0 to 100

#4 Updated by Tuukka Lehtonen almost 4 years ago

  • Category set to Typicals
  • Status changed from Feedback to Closed

Also available in: Atom PDF