Bug #3841

Apros export fails.

Added by Kalle Kondelin over 5 years ago. Updated about 5 years ago.

Status:ClosedStart date:
Priority:4Due date:
Assignee:Kalle Kondelin% Done:

100%

Category:DB clientSpent time:-
Target version:2012-20
Release notes:
Story pointsS
Velocity based estimate-
ReleaseSimantics 1.8Release relationshipAuto

History

#1 Updated by Kalle Kondelin over 5 years ago

  • Category set to DB client
  • Status changed from New to Feedback
  • Assignee set to Kalle Kondelin
  • % Done changed from 0 to 100

Tuomas reported that export with Apros 6.02 RC2 failed. I tested this and model export generated the following errors:

0 [ ModalContext] ERROR ics.db.common.utils.LogManager - org.simantics.db.exception.DatabaseException: Id has not been created for $668860630 : (Connection)
org.simantics.db.exception.DatabaseException: org.simantics.db.exception.DatabaseException: Id has not been created for $668860630 : (Connection)
at org.simantics.graph.db.TransferableGraphs$14.run(TransferableGraphs.java:417)
at org.simantics.db.common.request.ReadRequest.perform(ReadRequest.java:21)
at fi.vtt.simantics.procore.internal.SessionImplSocket$6.run(SessionImplSocket.java:1361)
at fi.vtt.simantics.procore.internal.SessionRequestManager$1.run(SessionRequestManager.java:112)
at org.simantics.db.impl.query.QueryProcessor$QueryThread.run(QueryProcessor.java:525)
Caused by: org.simantics.db.exception.DatabaseException: Id has not been created for $668860630 : (Connection)
at org.simantics.db.layer0.util.ModelTransferableGraphSource.getExistingId(ModelTransferableGraphSource.java:130)
at org.simantics.db.layer0.util.ModelTransferableGraphSource.forStatements(ModelTransferableGraphSource.java:226)
at org.simantics.graph.db.TransferableGraphs$14.run(TransferableGraphs.java:386)
... 4 more

With Antti's and Hannu's help I finally managed to remove the mapping relation from the connections and got the export to work. Hannu had an idea how the export code could be improved to handle these kind of detached connections. How these connections have been created remains a mystery.

#2 Updated by Tuukka Lehtonen about 5 years ago

  • Status changed from Feedback to Closed

Also available in: Atom PDF